1021. Deepest Root (25)

1021. Deepest Root (25)

时间限制
1500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:

Error: 2 components


#include<iostream>
#include<string.h>
#include<map>
#include<vector>
#include<set>
using namespace std;
#define SIZE 10001

int pre[SIZE];
int cnt;
map<int, vector<int>> tree;
int length[SIZE];

int root(int a){
	int ans = a;
	while (ans != pre[ans])
		ans = pre[ans];
	return ans;
}

void merge(int a, int b){
	int ra = root(a);
	int rb = root(b);
	if (ra != rb){
		pre[rb] = ra;
		cnt--;
	}
}

void dfs(int a){
	vector<int>::iterator iter;
	for (iter = tree[a].begin(); iter != tree[a].end(); iter++){
		if (length[*iter] == 0){
			length[*iter] = length[a] + 1;
			dfs(*iter);
		}
	}
	return;
}

int main(){
	int n,a,b;
	set<int> s,ss;
	cin >> n;
	cnt = n;
	for (int i = 0; i <= n;i++)
		pre[i] = i;
	for (int i = 1; i < n; i++){
		cin >> a >> b;
		tree[a].push_back(b);
		tree[b].push_back(a);
		merge(a, b);
	}
	if (cnt != 1){
		cout << "Error: " << cnt << " components" << endl;
		return 0;
	}
	length[1] = 1;
	dfs(1);
	int max = 0, index = 1;
	for (int i = 1; i <= n; i++){
		if (length[i] > max){
			max = length[i];
			ss.clear();
			ss.insert(i);
		}
		else if (length[i] == max)
			ss.insert(i);
	}
	max = 0;
	set<int>::iterator it = ss.begin();
	memset(length, 0, sizeof(int)*(n + 1));
	length[*it] = 1;
	dfs(*it);
	for (int i = 1; i <= n; i++){
		if (length[i] > max){
			max = length[i];
			s.clear();
			s.insert(i);
		}
		else if (length[i] == max){
			s.insert(i);
		}
	}
	for (set<int>::iterator it = ss.begin(); it != ss.end(); it++)
		s.insert(*it);

	for (set<int>::iterator iter = s.begin(); iter != s.end(); iter++){
		cout << *iter << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值