杭电OJ:3139-Soda Surpler

Soda Surpler

Problem Description

Tim is an absolutely obsessive soda drinker, he simply cannot get enough. Most annoyingly though, he almost never has any money, so his only obvious legal way to obtain more soda is to take the money he gets when he recycles empty soda bottles to buy new ones. In addition to the empty bottles resulting from his own consumption he sometimes find empty bottles in the street. One day he was extra thirsty, so he actually drank sodas until he couldn't afford a new one.

Input

Three non-negative integers e, f, c, where e < 1000 equals the number of empty soda bottles in Tim's possession at the start of the day, f < 1000 the number of empty soda bottles found during the day, and 1 < c < 2000 the number of empty bottles required to buy a new soda.

Output

How many sodas did Tim drink on his extra thirsty day?

Sample Input

9 0 3

5 5 2

Sample Output

4

9

 

问题描述

Tim是一个绝对痴迷的苏打水饮用者,他根本无法得到足够的。但最令人讨厌的是,他几乎从来没有钱,所以他获得更多汽水的唯一明显合法途径就是拿他回收空汽水瓶时得到的钱购买新汽水瓶。除了自己消费产生的空瓶子外,他有时会在街上找到空瓶子。有一天他特别渴,所以他真的喝了苏打水,直到他买不起新的。

输入

三个非负整数efc其中e < 1000 等于一天开始时 Tim 拥有的空汽水瓶的数量,f < 1000 是当天发现的空汽水瓶的数量,1 < c < 2000 购买新汽水所需的空瓶数。

输出

Tim特别渴的那天喝了多少苏打水?

样本输入

9 0 3

5 5 2

样本输出

4

9

 

#include<bits/stdc++.h>
#include <iostream>
#include<cstdio>
using namespace std;

int main(){
	int e,f,c;
	int ans;
	while(cin>>e>>f>>c)
	{
		e+=f;
		ans=0;
		while(e>=c){
			ans+=e/c;
			e=e/c+e%c;
		}
		cout<<ans<<endl;
	}
	
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值