1046. Shortest Distance

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:
3
10
7



import java.util.Scanner;


public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);

        int n = sc.nextInt();
        int[] dist = new int[1+n];

        int sum = 0;
        for(int i=2; i<1+n; i++) {
            sum += sc.nextInt();
            dist[i] = sum;
        }
        sum += sc.nextInt();
        int half = sum / 2;

        int m = sc.nextInt();       
        for(int i=0; i<m; i++) {
            int s = sc.nextInt();
            int t = sc.nextInt();

            int d1 = 0;
            if(s > t)
                d1 = dist[s] - dist[t];
            else
                d1 = dist[t] - dist[s];

            if(d1 <= half)
                System.out.println(d1);
            else
                System.out.println(sum - d1);
        }

    }
}
#include <iostream>  
#include <vector>  
#include <stdio.h>  
#include <math.h>  

using namespace std;  

vector<int> dis;  
vector<int> disToOrigin;  
int sum = 0;  

int computeMinDis(int s, int e){  
    int minDist1 = 0,minDist2 = 0;  
    int start, end;  
    if(s < e) { start = s; end = e; }  
    else if( s == e ) return 0;  
    else { start = e; end = s; }  
    minDist1 = disToOrigin[end] - disToOrigin[start];  
    minDist2 = sum - minDist1;  
    return minDist1 < minDist2 ? minDist1 : minDist2;  
}  

int main()  
{  
    int N,M;  
    cin >> N;  
    dis.resize(N+1);  
    disToOrigin.resize(N+1);  
    disToOrigin[1] = 0;  
    int value;  
    for(int i = 1; i <= N; i++){  
        scanf("%d",&value);  
        dis[i] = value;  
        if(i > 1) disToOrigin[i] = sum;  
        sum += value;  
    }  
    cin >> M;  
    int x,y;  
    for(int i = 0; i < M; i++){  
        scanf("%d%d",&x,&y);  
        printf("%d\n",computeMinDis(x,y));  
    }  
    return 0;  
} 

我表示内心是崩溃的,Java一直运行超时,然而和C++算法都是一样的,

由此可见Java和C++的运行效率的差别

刷PAT真是好蛋疼啊,别人全部刷完时有多屌????

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值