PAT-A 1046 Shortest Distance (20 分)

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

思路:

1.在一个封闭圆环上,从一个点到另一个点可以走顺时针方向,也可以走逆时针方向,最短距离为走两个方向的距离中较小的那个。

2.如果对于每一对给定的点,都进行遍历计算,在题目条件的极限情况下(105个点,104对距离),肯定会超时。 

3.假设出口点从0开始编号,保存从出口0到出口m的距离,在计算两个点之间顺时针的距离时,可以借助出口0到这两个点之间的距离,这样计算时间复杂度可以降到O(1).

#include <cstdio>
#include <cmath>

int main()
{
    int N;
    scanf("%d", &N);

    int distance[N];
    int total = 0;
    int first_to_i[N];
    for(int i = 0; i < N; i++)
    {
        scanf("%d", distance + i);
        total += distance[i];
        //保存0点到其他点的距离,
        //最后一个数值可以认为是顺时针0到0的距离
        first_to_i[i] = total;
    }

    int k;
    scanf("%d", &k);
    for(int i = 0; i < k; i++)
    {
        int small, big;
        scanf("%d %d", &small, &big);

        //两个点的编号都减1,表示从0开始编号
        small -= 1;
        big -= 1;

        if(small > big)
        {   //让small始终代表小的标号
            small = small ^ big;
            big = small ^ big;
            small = small ^ big;
        }

        int clock;//从小编号到大编号顺时针的距离
        int anti_clock;//从小编号到大编号逆时针的距离
        if(small == 0)
            clock = first_to_i[big - 1];
        else
            clock = first_to_i[big - 1] - first_to_i[small - 1];

        anti_clock = total - clock;
        //输出顺时针和逆时针距离中较小的那个
        printf("%d", clock < anti_clock ? clock : anti_clock);
        if(i != k - 1)
            printf("\n");
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值