1058. A+B in Hogwarts (20)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1058
题意

给定的数的结构如下:a.b.c,其中 a 的范围是 [0, 107],b 的范围是 [0,17),c 的范围是 [0,29)。给定两个数,要求计算他们的和。

分析

简单模拟题,有一个坑:题目交代最高位的区间为 [0, 100000000],但是没说如果两数相加超过这个值怎么办。需要将最高位的结果区间设定为 20000000 以上才 AC。

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
	long a[3];
	long b[3];
	scanf("%ld.%ld.%ld",&a[0],&a[1],&a[2]);
	scanf("%ld.%ld.%ld",&b[0],&b[1],&b[2]);
	int tmp;
	tmp=a[2]+b[2];
	if(tmp>=29){
		a[2]=tmp-29;
		a[1]++;
	}
	else
		a[2]=tmp;
	tmp=a[1]+b[1];
	if(tmp>=17){
		a[1]=tmp-17;
		a[0]++;
	}
	else
		a[1]=tmp;
	a[0]+=b[0];
	int i=0;
	cout<<a[0]<<"."<<a[1]<<"."<<a[2]<<endl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值