2013杭州区域赛现场赛 B && HDOJ 4771 —— 搜索

4 篇文章 0 订阅

Stealing Harry Potter's Precious

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 129    Accepted Submission(s): 66


Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
 

Input
  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
 

Sample Input
  
  
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
 

Sample Output
  
  
-1 5
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4780  4779  4778  4777  4776 
 
题意是给你一个图 . 表示可以走, #表示不能走,@是起点,然后告诉你一些点,问你从起点开始经过所有点的最短距离。
思路:先BFS扩展出所有点的dis, 然后DFS出路径的距离。
/*
ID: xinming2
PROG: stall4
LANG: C++
*/
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <cassert>
using namespace std;
///#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1 | 1
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 30 + 5;
const int sigma_size = 26;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7f7f7f7f;
const int IMIN = 0x80000000;
#define eps 1e-8
const int mod = (int)1e9 + 7;
typedef long long LL;
const LL MOD = 1000000007LL;
const double PI = acos(-1.0);

typedef pair<int , int> pi;
#define Bug(s) cout << "s = " << s << endl;
///#pragma comment(linker, "/STACK:102400000,102400000")
pair<int , int> s[12];
int n , m , num , ans;
char G[120][120];
int dis[12][12];
int dx[4] = {1 , 0 , 0 , -1};
int dy[4] = {0 , 1 , -1 , 0};
int vis[120][120];
void bfs(int id)
{
    queue <pair<pair<int , int > , int > >q;
    clr(vis , 0);
    q.push(mk(s[id] , 0));
    dis[id][id] = 0;
    vis[s[id].first][s[id].second] = 1;
    while(!q.empty())
    {
        int x = q.front().first.first;
        int y = q.front().first.second;
        int d = q.front().second;
        q.pop();
        for(int i = 0 ; i < 4 ; i++)
        {
            int nx = x + dx[i] , ny = y + dy[i];
            if(0 > nx || nx >= n || ny < 0 || ny >= m)continue;
            if(G[nx][ny] == '#')continue;
            if(!vis[nx][ny])
            {
                vis[nx][ny] = 1;
                q.push(mk(mk(nx , ny) , d + 1));
                for(int j = 0 ; j <= num ; j ++)
                {
                    if(nx == s[j].first && ny == s[j].second)
                    {
                        dis[id][j] = d + 1;
                    }
                }
            }
        }
    }
}
void dfs(int id , int mk , int step)
{
    mk = mk | (1 << id);
    if(mk == (1 << (num + 1)) - 1)ans = min(ans , step);
    for(int i = 0 ; i <= num ; i++)
    {
        if(mk & (1 << i) || dis[id][i] == INF)continue;
        dfs(i , mk , step + dis[id][i]);
    }
}
int main()
{
    while(~scanf("%d%d" , &n , &m) , m || n)
    {
        for(int i = 0 ; i < n ; i++)
        {
            scanf("%s" , G[i]);
            for(int j = 0 ; j < m ; j++)
            {
                if(G[i][j] == '@')
                {
                    s[0] = mk(i , j);
                }
            }
        }
        scanf("%d" , &num);
        for(int i = 1 ; i <= num ; i++)
        {
            scanf("%d%d" , &s[i].first, &s[i].second);
            s[i].first --;
            s[i].second --;
        }
        for(int  i = 0 ; i <= 10 ; i++)for(int j = 0 ; j <= 10 ; j++)dis[i][j] = INF;
        for(int i = 0 ;i <= num ; i++)bfs(i);
        ans = INF;
        dfs(0 , 0 , 0);
        if(ans == INF)puts("-1");
        else printf("%d\n" , ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值