UVA 10783 - Odd Sum

  Odd Sum 

Given a range  [ab] , you are to find the summation of all the odd integers in this range. For example, the summation of all the odd integers in the range  [3, 9]  is  3 + 5 + 7 + 9 = 24 .

Input 

There can be at multiple test cases. The first line of input gives you the number of test cases,  T  (   1$ \le$T$ \le$100 ). Then T test cases follow. Each test case consists of 2 integers  a  and  b  (   0$ \le$a$ \le$b$ \le$100 ) in two separate lines.

Output 

For each test case you are to print one line of output - the serial number of the test case followed by the summation of the odd integers in the range  [ab] .

Sample Input 

2
1
5
3
5

Sample Output 

Case 1: 9
Case 2: 8
秒之 大笑
#include<cstdio>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
#include<cmath>
#include <cstring>
#include <queue>
using namespace std;
#define eps 1e-20
#define MAXN 150
#define outstars cout << "*********" << endl;
int s[MAXN];
int main()
{
    int T;
    s[0] = 0;
    s[1] = 1;
    for(int i = 2 ; i <= 120 ; i++)
    {
        int x = i + i % 2 - 1;
        s[i] = x;
        while(x > 1)
        {
            x -= 2;
            s[i] += x;
        }
        //cout << i << ' ' << s[i] << endl;
    }

    cin >> T;
    for(int Case = 1 ; Case <= T ; Case ++)
    {
        int a , b;
        scanf("%d%d",&a,&b);
        printf("Case %d: %d\n",Case, s[b] - s[a - 1]);
    }
    return 0;
}
/*

*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值