2015计算机学科夏令营上机考试 I:Risk Floyd算法三层for循环 k->i->j

总时间限制: 1000ms 内存限制: 65536kB题目
描述
Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player’s turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country.

During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one.

The following connection diagram illustrates the first sample input.

输入
Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many “higher-numbered” countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest.

There can be multiple test sets in the input file; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.
输出
For each input set, your program should print the following message “Test Set #T” where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string ” to ” the destination country code B ; the string “: ” and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.
样例输入

1 3
2 3 4
3 4 5 6
1 6
1 7
2 12 13
1 8
2 9 10
1 11
1 11
2 12 17
1 14
2 14 15
2 15 16
1 16
1 19
2 18 19
1 20
1 20
5
1 20
2 9
19 5
18 19
16 20

样例输出

Test Set #1
1 to 20: 7
2 to 9: 5
19 to 5: 6
18 to 19: 2
16 to 20: 2

思路
1 dijstra算法只能求单源点最短路径,想求多源点最短路径用Floyd三重循环k->i->j k作为中间节点枚举(i , j)
2 dijstra算法时间复杂度O(n2) floyd是O(n3)
注意:第一次没看到下面这句,导致Presentation Error,一般这个错误就是输出格式错了,答案十有八九是对的。

Following all result lines of each input set, your program should print a single blank line.

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<set>
#include<stack>
using namespace std;
#define MAX 21
const int INF=0x3f3f3f;
int tag=1;
//dijstra 只能求单源点最短路径,floyd能求全源点最短路径
//floyd算法只需要一个dis矩阵即可,k->i->j三层for循环k作为中间节点枚举(i , j)

int dis[MAX][MAX];
void print(int tags)
{
    cout<<"Test Set #"<<tags<<endl;
}
void result(int x, int y)
{
    cout<<x<<" to "<<y<<": "<<dis[x][y]<<endl;
}
void floyd()
{
    for(int k=1;k<MAX;k++)
        for(int i=1;i<MAX;i++)
            for(int j=1;j<MAX;j++)
            {
                if(dis[i][k]+dis[k][j]<dis[i][j]&&dis[i][k]!=INF&&dis[k][j]!=INF)
                {
                    dis[i][j]=dis[i][k]+dis[k][j];
                }
            }
}
int main()
{
    //freopen("input.txt","r",stdin);
   int X;
   int tt=0;
   while(cin>>X)
   {
       if(!tt) tt=1;
       else cout<<endl;
       //初始化
       for(int i=0;i<MAX;i++)
        for(int j=0;j<MAX;j++)
            dis[i][j]=dis[j][i]=INF;
       //输入
        for(int j=0;j<X;j++)
           {
               int country;
               cin>>country;
              dis[1][country]=dis[country][1]=1;
           }
       for(int i=2;i<20;i++)
       {
           cin>>X;
           for(int j=0;j<X;j++)
           {
               int country;
               cin>>country;
              dis[i][country]=dis[country][i]=1;
           }
       }
       //计算最短距离
       floyd();
       //输出
       print(tag++);
       int  N;
       cin>>N;
       int x,y;
       for(int i=0;i<N;i++)
       {
           cin>>x>>y;
           result(x,y);
       }
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值