1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

注意到多项式的阶数1000以内,将两个多项式都扩展到1000个项,然后两个多项式相加就很简单了。

 

#include<iostream>
#include<vector>
#include<iomanip>
using namespace std;

int main()
{
  double ceofs[1001]={0};
  //for(int i=0;i<1001;++i) ceofs[i]=0;
  int n1;
  cin>>n1;
  while(n1>0)
  {
    int a;
    double b;
    cin>>a>>b;
    ceofs[a]+=b;
    n1--;
  }
  int n2;
  cin>>n2;
  while(n2>0)
  {
    int a;
    double b;
    cin>>a>>b;
    ceofs[a]+=b;
    n2--;
  }
  vector<int> orders;   //遍历系数一次,找出系数非0的项
  for(int i=1000;i>=0;--i)
  {
    if(ceofs[i]!=0)
    orders.push_back(i);
  }
  cout<<orders.size();
  cout<<fixed;
  for(int i=0;i<orders.size();++i)
  cout<<" "<<setprecision(1)<<orders[i]<<" "<<ceofs[orders[i]];
  cout<<endl;
  return 0;
}

增加了多项式项数,增加了空间复杂度,但编程简单。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值