2016多校训练Contest5: 1011 Two hdu5791

Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
 

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers  N,M(1N,M1000) . The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
 

Output
For each test case, output the answer mod 1000000007.
 

Sample Input
  
  
3 2 1 2 3 2 1 3 2 1 2 3 1 2
 

Sample Output
  
  
2 3

直接dp[i][j]暴表示第一个数列前i项第二个前j项的相同种数

然后暴力n^2转移即可

队友写的代码

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <stack>
using namespace std;
const int INF = 2147483647;
const double PI = acos(-1);
  
/* ----------------- code ----------------- */

int a[1010],dp[1010][1010],b[1010];
const int mod = 1000000007;
int main(void){

    int n,m;
       while(scanf("%d%d",&n,&m)!=EOF){
           for(int i=1;i<=n;i++){
               scanf("%d",&a[i]);
           }
           for(int i=1;i<=m;i++){
               scanf("%d",&b[i]);
           }
           memset(dp,0,sizeof(dp));
           for(int i=1;i<=n;i++){
               for(int j=1;j<=m;j++){
                   dp[i][j] = ((( (dp[i - 1][j] + dp[i][j - 1]) % mod - dp[i - 1][j - 1] ) % mod + mod) % mod + (a[i] == b[j] ? dp[i - 1][j - 1] + 1 : 0) ) % mod;
               }
           }
           /*
           for(int i=0;i<=n;i++){
               for(int j=0;j<=m;j++){
                   printf("%d ",dp[i][j]);
               }
               printf("\n");
           }
           */
           printf("%d\n",dp[n][m]%mod);
       }
  
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值