POJ 3352 Road Construction

Road Construction
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10183 Accepted: 5057

Description

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

Source

CCC 2007

要修路,问至少要多修几条路才能保证,当以条路被占用的时候,任意两点还能互达。即求加边构造强连通的图。

ACcode:

#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 100005
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
struct Edge{
    int to,next;
    bool cut;
}e[maxn];
int head[maxn],cnt;
int low[maxn],dfn[maxn],Stack[maxn],belong[maxn],du[maxn];
int pos,top,block,bridge;
bool instack[maxn];
void addEdge(int u,int v){
    e[cnt].to=v;e[cnt].next=head[u];
    e[cnt].cut=false;head[u]=cnt++;
}
void tarjan(int u,int pre){
    int v;
    low[u]=dfn[u]=++pos;
    Stack[top++]=u;
    instack[u]=true;
    for(int i=head[u];i!=-1;i=e[i].next){
        v=e[i].to;
        if(v==pre)continue;
        if(!dfn[v]){
            tarjan(v,u);
            if(low[u]>low[v])low[u]=low[v];
            if(low[v]>dfn[u]){
                bridge++;
                e[i].cut=true;
                e[i^1].cut=true;
            }
        }
        else if(instack[v]&&low[u]>dfn[v])
            low[u]=dfn[v];
    }
    if(low[u]==dfn[u]){
        block++;
        do{
            v=Stack[--top];
            instack[v]=false;
            belong[v]=block;
        }
        while(v!=u);
    }
}
void init(){
    cnt=pos=top=block=bridge=0;
    MT(head,-1); MT(dfn,0);
    MT(instack,false);MT(du,0);
}
void solve(int n){
    tarjan(1,0);
    int ans=0;
    FOR(i,1,n){
        for(int k=head[i];k!=-1;k=e[k].next)
                if(e[k].cut)
                    du[belong[i]]++;
    }
    FOR(i,1,block)
        if(du[i]==1)
            ans++;
    printf("%d\n",(ans+1)/2);
}
int main(){
    int n,m,u,v;
    while(rd2(n,m)!=EOF){
        init();
        FOR(i,1,m){
            rd2(u,v);
            addEdge(u,v);
            addEdge(v,u);
        }
        solve(n);
    }
    return 0;
}
/*
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10
3 3
1 2
2 3
1 3
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值