山东省第五届ACM大学生程序设计竞赛 Weighted Median

Weighted Median

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

For n elements x1, x2, ..., xn with positive integer weights w1, w2, ..., wn. The weighted median is the element xk satisfying
 and   , S indicates 
Can you compute the weighted median in O(n) worst-case?
 

输入

There are several test cases. For each case, the first line contains one integer n(1 ≤  n ≤ 10^7) — the number of elements in the sequence. The following line contains n integer numbers xi (0 ≤ xi ≤ 10^9). The last line contains n integer numbers wi (0 < wi < 10^9).
 

输出

One line for each case, print a single integer number— the weighted median of the sequence.
 

示例输入

7
10 35 5 10 15 5 20
10 35 5 10 15 5 20

示例输出

20

提示

The S which indicates the sum of all weights may be exceed a 32-bit integer. If S is 5,  equals 2.5.

来源

2014年山东省第五届ACM大学生程序设计竞赛

示例程序

 

按照题目要求写就行了

ACcode:

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 10000010
#define ll long double
using namespace std;
struct N{
    int x;
    int w;
    bool operator<(const N &b)const{return this->x<b.x;}
}my[maxn];
int main(){
    int n,ans;
    ll sum,tt;
    while(~scanf("%d",&n)){
        sum=0;
        for(int i=1;i<=n;++i)
            scanf("%d",&my[i].x);
        for(int i=1;i<=n;++i){
            scanf("%d",&my[i].w);
            sum+=my[i].w;
        }
        sort(my+1,my+1+n);
        tt=my[1].w;
        for(int i=1;i<n;++i)
            if(tt+my[i+1].w<sum/2)tt+=my[i+1].w;
            else {ans=my[i+1].x;break;}
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值