ACM第五届山东省赛 J-Weighted Median

G-Weighted Median

Time Limit: 2000 ms   Memory Limit: 65536 KiB

Problem Description
For n elements x1, x2, …, xn with positive integer weights w1, w2, …, wn. The weighted median is the element xk satisfying
xi<xkωi<S2 ∑ x i < x k ω i < S 2 and xi>xkωiS2 ∑ x i > x k ω i ≤ S 2 ,S indicates ni=1ωi ∑ i = 1 n ω i
Can you compute the weighted median in O(n) worst-case?

Input
There are several test cases. For each case, the first line contains one integer n(1 ≤  n ≤ 10^7) — the number of elements in the sequence. The following line contains n integer numbers xi (0 ≤ xi ≤ 10^9). The last line contains n integer numbers wi (0 < wi < 10^9).

Output
One line for each case, print a single integer number— the weighted median of the sequence.

Sample Input
7
10 35 5 10 15 5 20
10 35 5 10 15 5 20

Sample Output
20

Hint
The S which indicates the sum of all weights may be exceed a 32-bit integer. If S is 5, equals 2.5.

题目链接:http://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Index/problemdetail/pid/2886.html

本题的题意:给出一组序列,求一个 xk x k 满足: xi<xkωi<S2 ∑ x i < x k ω i < S 2 and xi>xkωiS2 ∑ x i > x k ω i ≤ S 2 ,S indicates ni=1ωi ∑ i = 1 n ω i

参考代码

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define N 10000010
struct node{
    int x;
    int w;
}s[N];
int cmp(struct node a, struct node b)
{
    return a.x < b.x;
}
int main(void)
{
    int n;
    int i, j;
    double sum, judge, suma;
    while(scanf("%d", &n) != EOF){
        sum = suma = 0;
        for(i = 0; i < n; i++)
            scanf("%d", &s[i].x);
        for(i = 0; i < n; i++){
            scanf("%d", &s[i].w);
            sum += s[i].w;
        }
        judge = sum/2.0;
        sort(s, s+n, cmp);
        for(i = 0; i < n; i++){
            suma += s[i].w;
            if(suma > sum/2.0){
                printf("%d\n", s[i].x);
                break;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值