POJ 2318 TOYS 叉积的应用

A - TOYS
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m  x1  y1  x2  y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are ( x1, y1) and ( x2, y2), respectively. The following n lines contain two integers per line,  Ui Li, indicating that the ends of the  i-thcardboard partition is at the coordinates ( Ui, y1) and (Li, y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line,  Xj  Yj specifying where the  j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2

4: 2

给你n条线把一个长方形分割成n+1个空间

给你m个点让你判断这m个点分别在哪些空间中并统计个数

一开始想复杂了 想通过判断点是否在这n+1个4边形中

后来发现只要找到离每个点右边最近的那条线段的编号就可以确定该点属于哪个空间了

这里利用叉积的知识 对于向量 P和Q 

P*Q>0 则P在Q顺时针方向

P*Q<0 则P在Q逆时针方向

P*Q=0 P与Q共线 不一定同向

连接 点 p和 每条线段的下面那个点形成向量就可以通过叉积判断点对于不同线段的位置

这里我们采取二分线段来确定点在的区域

ACcode:

#include <cstring>
#include <cstdio>
#define maxn 5050
struct  Point{
    int x,y;
    Point (){}
    Point(int _x,int _y){
        x=_x;
        y=_y;
    }
}p[maxn];
struct Line{
    Point s,e;
    Line(){}
    Line(Point _s,Point _e){
        s=_s;
        e=_e;
    }
}my[maxn];
int ans[maxn];
int multi(Point p1,Point  p2,Point p0){
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
int main(){
    int n,m,x1,y1,x2,y2;
    while(~scanf("%d",&n),n){
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        for(int i=0;i<n;++i){
            int a,b;
            scanf("%d%d",&a,&b);
            my[i]=Line(Point(a,y1),Point(b,y2));
        }
        my[n]=Line(Point(x2,y1),Point(x2,y2));
        memset(ans,0,sizeof(ans));
        for(int i=1;i<=m;++i){
            int x,y;
            scanf("%d%d",&x,&y);
            Point tmp=Point(x,y);
            int l=0,r=n,id;
            while(l<=r){
                int mid=(l+r)>>1;
                if(multi(my[mid].s,my[mid].e,tmp)<0){
                    id=mid;
                    r=mid-1;
                }
                else l=mid+1;
            }
            ans[id]++;
        }
        for(int i=0;i<=n;++i)
            printf("%d: %d\n",i,ans[i]);
        putchar('\n');
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值