3-2 3.2判断分数等级

3-2 3.2判断分数等级

3.2.A student’s letter grade is calculated according to the following schedule.Write a C program that accepts a student’s numerical grade,converts the numerical grade to an equivalent letter grade,and display the letter grade.Hint: The input range is [0,100](10分)

Numerical Letter Grade
Greater than or equal to 90 A
Less than 90 but greater than or equal to 80 B
Less than 80 but greater than or equal to 70 C
Less than 70 but greater than or equal to 60 D
Less than 60 F

输入格式:
在一行中输入一个整数n。

输出格式:
对每一组输入n,在一行中输出n对应的等级。

输入样例:
在这里给出一组输入。例如:

100
输出样例:
在这里给出相应的输出。例如:

A

#include<stdio.h>
int main()
{  
	int n;
	scanf("%d",&n);
	
    if(n<0||n>100)
      printf("输入有区间为[0,100]之间的整数");
    else
      switch(n/10)
	{
		case 10: case 9:
			printf("A");
			break;
		case 8: 
			printf("B");
			break;
		case 7: 
			printf("C");
			break;
		case 6: 
			printf("D");
			break;
        default:
		case 5: case 4: case 3:
		case 2: case 1: case 0:
			printf("F");
			break;		
	}
return 0;

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小小*白

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值