3-4 3.4编程计算一元二次方程的根

3-4 3.4编程计算一元二次方程的根

3.4. A quadratic equation is an equation that either has the from or an equation that can be algebraically manipulated into this form. In this equation,x is the unknown variable ,and a,b,and c are known constants.Although the constants b and c can be any numbers,including 0, the value of the constant a cannot be 0(if a is 0,the equation would become a liner equation in x).Examples quadratic equations are

三个方程.png
请添加图片描述
In the first equation a=5,b=6,c=2;in the second equation a=1,b=-7,and c=20;and in the third equation a=34,b=0,and c=16.
The real roots of a quadratic equation can be calculated using the quadratic formula as follows:

第一个根.png
请添加图片描述

and:

第二个根.png
请添加图片描述

Using these equations,write a C program to solve for the roots of a quadratic equation.Hint:Tip: no solution shows no real number solution,Accurately six digits after the decimal point(20分)

输入格式:
输入在一行中输入一元二次方程的三个系数a、b和c。

输出格式:
对每一组输入,在一行中输出对应的两个根。

输入样例:
在这里给出一组输入。例如:

1 2 1
输出样例:
在这里给出相应的输出。例如:

-1.000000 -1.000000

#include<stdio.h>
#include<math.h>
int main()

{
    int a,b,c;
    double rootOne,rootTwo,d;
    scanf("%d %d %d",&a,&b,&c);
    d=b*b-4*a*c;
    if(d<0||a==0)
        printf("no real number solution");
    if(d>=0&&a!=0)
    {
        rootOne=((-b+sqrt(d))/(2*a));
        rootTwo=((-b-sqrt(d))/(2*a));
        printf("%.6lf %.6lf",rootOne,rootTwo);
    }
    
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小小*白

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值