light oj 1005 Rooks(组合数)

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are not. R2 and R3 are also in non-attacking positions.

Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x n chessboard so that no two of them are in attacking positions.


Input

Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output

For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input

8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output

Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0


题意:给你一个n*n的棋盘和k个车,要求将k个车全部放在棋盘中,使得每两个车不能互相攻击,问有多少种放法。


一眼想到搜索,就写了一发,T了,搜索通不过。然后感觉有规律,就手推了下规律,发现方案数是个组合数,即总共的方案数为 C(n,k)*C(n,k)*k!。后来又优化了下公式,发现其实是C(n,k)*A(n,k)。

坑点:当k等于0的时候,方案数为1,当k>n时,方案数为0。


下面贴上超时的代码:

#include <bits/stdc++.h>
#define N 500
using namespace std;
typedef long long ll;
ll sum;
int rol[50],row[50];
int t,n,k;

void dfs(int l,int step)
{
    if(step==k+1)
    {
        sum++;
        return;
    }
    for(int i=l; i<=n; i++)
        for(int j=1; j<=n; j++)
        {
            if(rol[i]==0&&row[j]==0)
            {
                rol[i]=row[j]=1;
                dfs(i,step+1);
                rol[i]=row[j]=0;
            }
        }
    return;
}

int main()
{
    cin>>t;
    for(int cas=1; cas<=t; cas++)
    {
        cin>>n>>k;
        sum=0;
        memset(rol,0,sizeof(rol));
        memset(row,0,sizeof(row));
        dfs(1,1);
        cout<<"Case "<<cas<<": "<<sum<<endl;
    }
    return 0;
}

没优化前的组合数代码:

#include <bits/stdc++.h>
#define N 500
using namespace std;
typedef long long ll;

ll dp[50][50],a[50][50];

void init()
{
    for(int i=1; i<=35; i++)
        a[i][1]=i;
    for(int i=1; i<=35; i++)
        for(int j=1; j<=i; j++)
            a[i][j+1]=a[i][j]*(i-j)/(j+1);//求C(n,k)

    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=1; i<=35; i++)
    {
         dp[i][i]=dp[i-1][i-1]*i;
         dp[i][0]=1;
    }

    for(int i=1; i<=35; i++)
        for(int j=1; j<=i; j++)
            dp[i][j]=a[i][j]*a[i][j]*dp[j][j];//C(n,k)*C(n,k)*k!
}

int main()
{
    init();
    int t,n,k;
    cin>>t;
    for(int cas=1;cas<=t;cas++)
    {
        cin>>n>>k;
        cout<<"Case "<<cas<<": "<<dp[n][k]<<endl;
    }
    return 0;
}


优化后的组合数代码:

#include <bits/stdc++.h>
#define N 500
using namespace std;
typedef long long ll;

ll dp[50][50];

void init()
{
    ll i,j;
    for(i=1; i<=35; i++)
        dp[i][1]=i*i,dp[i][0]=1;
    for(i=1; i<=35; i++)
        for(j=1; j<=i; j++)
            dp[i][j+1]=dp[i][j]*(i-j)/(j+1)*(i-j);//递推求解C(n,k)*A(n,k)
}

int main()
{
    init();
    int t,n,k;
    cin>>t;
    for(int cas=1;cas<=t;cas++)
    {
        cin>>n>>k;
        cout<<"Case "<<cas<<": "<<dp[n][k]<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值