hdu1423Greatest Common Increasing Subsequence(最长公共递增子序列)

Greatest Common Increasing Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 3
Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2
 

Source

ACM暑期集训队练习赛(二)

题意:

求两个数组的最长公共递增子序列

#include<cstdio>
#include<cstring>
int a[10000],b[10000],dp[1000][1000];
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int x1,x2,i,j,max1;
        scanf("%d",&x1);
        for(i=0;i<x1;i++)
        scanf("%d",&a[i]);
        scanf("%d",&x2);
        for(i=0;i<x2;i++)
        scanf("%d",&b[i]);
        memset(dp,0,sizeof(dp));
        for(i=1;i<=x1;i++)
        {
            max1=0;
            for(j=1;j<=x2;j++)
            {
                dp[i][j]=dp[i-1][j];//至少等于前面的
                if(a[i-1]>b[j-1]&&max1<dp[i-1][j])//有可能在公共子序列里面;
                    max1=dp[i-1][j];
                if(a[i-1]==b[j-1])//相等就说明是递增子序列里面的。
                    dp[i][j]=max1+1;
            }
        }
        max1=0;
        for(i=0;i<=x1;i++)//找出较大的
            for(j=0;j<=x2;j++)
            if(max1<dp[i][j])
            max1=dp[i][j];
        printf("%d\n",max1);
        if(n)printf("\n");//注意就是最后的没有换行。
    }


}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值