Friends

Friends

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi <nui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4
 
AC代码:
 
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int a[200][200];
int main()
{
	int N,n,m,t,i,j,k,c,b,cnt,sign,cn;
	scanf("%d",&N);
	while(N--)
	{
		memset(a,0,sizeof(a));
		
		scanf("%d%d%d",&n,&m,&t); 
		cnt=0;
		for(i=0;i<m;++i)
		{
			scanf("%d%d",&c,&b);
			a[c][b]=1;
			a[b][c]=1;
		}
		sign=1;
		while(sign)
		{
			sign=0;
			for(i=0;i<n;++i)
			{
				for(j=i+1;j<n;++j)
				{
					if(a[i][j])continue;
					for(cn=0,k=0;cn<n;++cn)
					{
						if(a[i][cn]&&a[j][cn])k++;
					}
					if(k>=t)
					{
						a[j][i]=1;
						a[i][j]=1;
						cnt++;
						sign=1;
					}
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}
  为什么写成函数形式会错???
WA代码:
 
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int a[200][200];
int solve(int i,int j,int n,int f)
{
	int k,t=0;
	for(k=0;k<n;++k)
	{
		if(a[i][k]&&a[j][k])
		t++;
	}
	return t>=f?t:0;
}
int main()
{
	int N,n,m,t,i,j,k,c,b,cnt,sign;
	scanf("%d",&N);
	while(N--)
	{
		memset(a,0,sizeof(a));
		scanf("%d%d%d",&n,&m,&t);
		cnt=0;
		for(i=0;i<m;++i)
		{
			scanf("%d%d",&c,&b);
			a[c][b]=1;
			a[b][c]=1;
		}
		sign=1;
		while(sign)
		{
			sign=0;
			for(i=0;i<n;++i)
			{
				for(j=i+1;j<n;++j)
				{
					if(a[i][j])continue;
					k=solve(i,j,n,t);
					if(k)
					{
						a[j][i]=1;
						a[i][j]=1;
						cnt++;
						sign=1;
					}
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值