Friends ZOJ - 3710

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

 

Input

There are multiple test cases.

The first lien of the input contains an integer T(about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by mlines showing the current friendship. The ithfriendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

 

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

 

Sample Output

 

2
0
4

题意: 如果两个人有不少于k个共同的朋友,他们也会成为朋友。

输入:T:测试用例的数量。第一行:n、m、k (1<= n<=100, 0 <=m<=n*(n-1)/2, 0<= k<= n)没有重复的友谊)。

n:一共有多少人。m行,表示当前的友谊。第i个友谊包含两个整数ui vi (0<=ui, vi<n, ui!=vi),表示ui和vi之间存在友谊。

输出:新建的友谊有多少。


#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
#include<set>
#include<map>
using namespace std;
int mapp[510][510];
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n,m,k;
        int cnt;
        scanf("%d%d%d", &n, &m, &k);
        int sum=0;
        memset(mapp, 0, sizeof(mapp));
        //自己跟自己算是已经存在的友谊;
        for(int i=0; i<n; i++)
        {
            mapp[i][i]=1;
        }
        //友谊是双向的,所以都要标记;
        for(int i=0; i<m; i++)
        {
            int a, b;
            scanf("%d%d", &a, &b);
            mapp[a][b] = mapp[b][a] = 1;
        }
        while(1)
        {
            int flag=0;
            for(int i=0; i<n; i++)
            {
                for(int j=0; j<n; j++)
                {
                    //如果现在没有存在这个友谊;
                    if(mapp[i][j]==0)
                    {
                        cnt=0;
                        //计算共同朋友的个数;
                        for(int h=0; h<n; h++)
                        {
                            if(mapp[i][h]==1&&mapp[j][h]==1)
                                cnt++;
                        }
                        //如果有k个以上共同的朋友,那么就可以产生新友谊;
                        if(cnt>=k)
                        {
                            mapp[i][j]=1;
                            mapp[j][i]=1;
                            sum++;
                            flag=1;
                        }
                    }
                }
            }
            //所有关系遍历完跳出循环;
            if(flag==0)
            {
                break;
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值