A Knight's Journey(dfs+最小字典序)

A - A Knight's Journey
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
   
这题的搜索不难,难在字典序。而看了看题解后发现是有规律的。只要每次dfs要从每列这样遍历,而且方向数组要从左到右,再从上到下的次序就能保证是最小的字典序了。
 
   
AC代码:
 
   
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
using namespace std;
#define CRL(a) memset(a,0,sizeof(a))
vector< pair<int,int> > k;
pair<int,int> v;
int n,m,flag,cnt;
int fx[][2] = {{-1,-2},{1,-2},{-2,-1},{2,-1}
             ,{-2,1},{2,1},{-1,2},{1,2}};
int map[55][55];
bool jugde(int x,int y)
{
	if(x>=1&&x<=n&&y>=1&&y<=m&&!map[x][y]){
		return true;
	}
	return false;
}
void dfs(int x,int y,int c)
{
	int tx,ty;
	if(c==n*m){flag=0;}
	if(!flag)return;
	for(int i=0;i<8;++i){
		v.first=x, tx = fx[i][0] + x;v.first=tx;
		v.second=y, ty = fx[i][1] + y;v.second=ty;
		if(jugde(tx,ty)){
			k.push_back(v);map[tx][ty]=1;
			dfs(tx,ty,c+1);
			if(!flag)return;
			  k.pop_back();
			  map[tx][ty]=0;
		}
	}
}
int main()
{
	/*freopen("input.txt","r",stdin);*/
	int N,i,j,c=0;
	scanf("%d",&N);
	while(N--)
	{
		flag = 1;cnt=0;
		scanf("%d%d",&n,&m);
		printf("Scenario #%d:\n",++c);
		for(i=1;i<=m&&flag;++i){
			for(j=1;j<=n&&flag;++j){
				map[j][i] = 1;//这里只是换了m,n位置而未换i,j所以wa了
				v.first = j,v.second = i;
				k.push_back(v);
				dfs(j,i,1);
				CRL(map);
				if(flag)
				k.clear();
		   }
		}
		if(!flag){
			for(i=0;i<k.size();++i){
				printf("%c%d",(k[i].second+'A'-1),k[i].first);
			}
			printf("\n");k.clear();
		}
		else
		{
			printf("impossible\n");
		}
		printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值