POJ 1077-Eight(BFS+优先队列)

Eight
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28463 Accepted: 12420 Special Judge

Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4 

 5  6  7  8 

 9 10 11 12 

13 14 15  x 

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 

 5  6  7  8    5  6  7  8    5  6  7  8    5  6  7  8 

 9  x 10 12    9 10  x 12    9 10 11 12    9 10 11 12 

13 14 11 15   13 14 11 15   13 14  x 15   13 14 15  x 

           r->           d->           r-> 

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle
 1  2  3 

 x  4  6 

 7  5  8 

is described by this list:
 1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.

Sample Input

 2  3  4  1  5  x  7  6  8 

Sample Output

ullddrurdllurdruldr

Source




题意:
  给出一个八数码给你,要你求出1,2,3,4,5,6,7,8,x的顺序。

思路:
  这题很明显用BFS来做,当我写好了代码才发现我竟然不会如何去剪枝,所以一直跑重复的点。之后去看了看题解发现直接用hash去保存九个位置就是这个算法的剪枝了,思维短路了,竟然没意识到应该用hash去剪枝。


AC代码:


#include<iostream>
#include<functional>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<cstdio>
#include<queue>
#include<cmath>
#include<map>
#include<set>
using namespace std;
#define CRL(a) memset(a,0,sizeof(a))
#define QWQ ios::sync_with_stdio(0)
#define inf 0x3f3f3f3f
typedef unsigned long long LL;
typedef  long long ll;

const int T = 500000+50;
const int mod = 1000000007;
char s[5][5];
int xy[][2]={{1,0},{0,-1},{-1,0},{0,1}};
char fx[] = {{'r'},{'u'},{'l'},{'d'}};

struct node
{
	char s[5][5];
	vector<char> ve;
	int c,x,y;
	node(){}
	bool operator<(const node& b)const{
		return c<b.c; 
	}
};

set<int> se;

inline int jugde(const node& b)
{
	int k=0;
	for(int i = 0;i<3;++i){
		for(int j=0;j<3;++j){
			if(b.s[i][j]=='0'+i*3+j+1)k++;
		}
	}
	return k;
}	
inline void Copy1(node& a,const node& b)
{
	for(int i=0;i<3;++i){
		a.s[i][0]=b.s[i][0],
		a.s[i][1]=b.s[i][1],
		a.s[i][2]=b.s[i][2];
		a.s[i][3]='\0';
	}
}
 
int Hash(const node& a)
{
	int sum = 0;
	for(int i=0;i<3;++i){
		for(int j=0;j<3;++j){
			if(a.s[i][j]=='x'){
				sum = sum*10;
			}
			else {
				sum = sum*10 + a.s[i][j]-'0';
			}
		}
	}
	return sum;
}

void BFS(int x,int y)
{
	se.clear();
	priority_queue<node> q;
	node t,tt;
	
	for(int i=0;i<3;++i){
		t.s[i][0]=s[i][0],
		t.s[i][1]=s[i][1],
		t.s[i][2]=s[i][2];
		t.s[i][3]='\0';
	}
	t.x=x,t.y=y;
	t.c = jugde(t);
	q.push(t);
	se.insert(Hash(t));
	while(!q.empty())
	{
		t = q.top();q.pop();
		if(t.c==8){
			for(int i=0;i<t.ve.size();++i){
				printf("%c",t.ve[i]);
			}
			printf("\n");
			break;
		}

		for(int j=0;j<4;++j){
			int tx = t.x + xy[j][1];
			int ty = t.y + xy[j][0];
			if(tx>=0&&tx<3&&ty>=0&&ty<3){
				tt.x = tx;
				tt.y = ty;
				
				Copy1(tt,t);
				swap(tt.s[tx][ty],tt.s[t.x][t.y]);
				tt.c = jugde(tt);
				tt.ve = t.ve;
				tt.ve.push_back(fx[j]);
				int tmp = Hash(tt);
				if(se.find(tmp)==se.end()){
					se.insert(tmp);
					q.push(tt);
				}
			}
		}
	}
}


int main()
{

#ifdef zsc
    freopen("input.txt","r",stdin);
#endif

	int i,j,u,v;
	while(~scanf(" %c",&s[0][0]))
	{
		for(i=1;i<9;++i){
			scanf(" %c",&s[i/3][i%3]);
			if(s[i/3][i%3]=='x')u=i/3,v=i%3;
		}
		BFS(u,v);
	}
  

    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值