文章目录
Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 200 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB
A1105 Spiral Matrix (25 point(s))
This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^4. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
Code
#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
#include <math.h>
using namespace std;
bool cmp(int a,int b){return a>b;}
int res[10010][10010];
int main(){
int n,m,tn,tm,N,t=0;
scanf("%d",&N);
vector<int> in(N);
for(int i=0;i<N;i++) scanf("%d",&in[i]);
sort(in.begin(),in.end(),cmp);
for (n = sqrt((double)N); n >= 1; n--) {
if (N % n == 0) {
m = N / n;
break;
}
}
int level = m / 2 + m % 2;
for (int i = 0; i < level; i++) {
for (int j = i; j <= n - 1 - i && t <= N - 1; j++)
res[i][j] = in[t++];
for (int j = i + 1; j <= m - 2 - i && t <= N - 1; j++)
res[j][n - 1 - i] = in[t++];
for (int j = n - i - 1; j >= i && t <= N - 1; j--)
res[m - 1 - i][j] = in[t++];
for (int j = m - 2 - i; j >= i + 1 && t <= N - 1; j--)
res[j][i] = in[t++];
}
for(int i=0;i<m;i++){
for(int j=0;j<n;j++){
if(j==0) printf("%d",res[i][j]);
else printf(" %d",res[i][j]);
}
printf("\n");
}
return 0;
}
Analysis
-蛇形输出。分四段。