文章目录
总题解目录
[PAT- Advanced Level] 甲级题解目录(Advanced Level)
B1019/A1069. The Black Hole of Numbers (20)
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 — the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767, we’ll get:
7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174
7641 – 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0, 10000).
Output Specification:
If all the 4 digits of N are the same, print in one line the equation “N – N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.
Sample Input 1:
6767
Sample Output 1:
7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 – 2222 = 0000
Analysis
- 输入一个数,按四位数的格式递减排序后的数字减去递增排序后的数字得到一个新的数,如此反复直至该数等于0或6174。
C++ Code
//NKW 乙级真题1009
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
bool cmp(int a, int b){
return a > b;
}
int toint(int a[]){
int sum = 0;
for (int i = 0; i < 4; i++)
sum = sum * 10 + a[i];
return sum;
}
void toarray(int a[], int b){
for (int i = 3; i >= 0; i--){
a[i] = b % 10;
b /= 10;
}
}
int main(){
int n, max, min, arr[4];
scanf("%d", &n);
do{
toarray(arr, n);
sort(arr, arr + 4);
min = toint(arr);
sort(arr, arr + 4, cmp);
max = toint(arr);
n = max - min;
printf("%04d - %04d = %04d\n", max, min, n);
} while (n != 0 && n != 6174);
return 0;
}