HDU:5499 SDOI(结构体技巧)

SDOI

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 896    Accepted Submission(s): 358


Problem Description
The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI.  n(n100)  people comes to the Select and there is  m(m50)  people who can go to the NOI.

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is  300 .

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is  x .(it is promised that not all person in one round is 0,in another way, x>0 ). So for this round,everyone's final mark equals to his/her original  mark(300/x) .

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as  0.3round1s  final mark +  0.7round2s  final mark.It is so great that there were no two persons who have the same Ultimate mark.

After we got everyone's Ultimate mark.We choose the persons as followed:

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.
2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.
 

Input
There is an integer  T(T100)  in the first line for the number of testcases and followed  T  testcases.

For each testcase, there are two integers  n  and  m  in the first line (nm) , standing for the number of people take part in SDOI and the allowance of the team.Followed with  n  lines,each line is an information of a person. Name(A string with length less than  20 ,only contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than  300 ) separated with a space.

 

Output
For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

Followed  m  lines,every line is the name of the team with their Ultimate mark decreasing.
 

Sample Input
  
  
2 10 8 dxy male 230 225 davidwang male 218 235 evensgn male 150 175 tpkuangmo female 34 21 guncuye male 5 15 faebdc male 245 250 lavender female 220 216 qmqmqm male 250 245 davidlee male 240 160 dxymeizi female 205 190 2 1 dxy male 300 300 dxymeizi female 0 0
 

Sample Output
  
  
The member list of Shandong team is as follows: faebdc qmqmqm davidwang dxy lavender dxymeizi davidlee evensgn The member list of Shandong team is as follows: dxymeizi Hint For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2. The Final of The Ultimate score is as followed faebdc 298.20 qmqmqm 295.80 davidwang 275.88 dxy 271.80 lavender 260.64 dxymeizi 233.40 davidlee 220.80 evensgn 201.00 tpkuangmo 29.88 guncuye 14.40 For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.
 

Source
 

Recommend
hujie



题目大意:选一群人去参加比赛,所以经过热身赛选拔,在这个热身赛中,如果没有女参加的话,就取最终成绩的前m名去参加比赛,如果有女的参加的话,最终选拔出来的队伍里必须最低有一个女性,即使按正常排位前m名没有女性,那么也要抽出后面的一位女性来替换第m名进入最终队伍;如果正常排位里前m名有女性,则按排名输出。
比赛的最终成绩=(第一圈的最高分/300)*第一圈的分数*0.3+ (第二圈的最高分/300)*第二圈的分数*0.7

代码如下:
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int sex;//sex=0为女性,sex=1为男性 
	char name[25];
	double score;
	double round1;
	double round2;
	int id;//没用到 
}per[110];
bool cmp(struct node a,struct node b)
{
	return a.score>b.score;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		double max1=-1,max2=-1;//求第一圈的最高分和第二圈的最高分 
		int flagnv=0;//判断是否有女性参加比赛 
		for(int i=0;i<n;i++)
		{
			char xing[10];
			scanf("%s %s %lf %lf",&per[i].name,xing,&per[i].round1,&per[i].round2);
			per[i].id=i;
			if(strcmp(xing,"male")==0)
			per[i].sex=1;
			else
			{
				per[i].sex=0;
				flagnv=1;
			}
			if(per[i].round1>max1)
			{
				max1=per[i].round1;
			}
			if(per[i].round2>max2)
			{
				max2=per[i].round2;
			}
		}
		for(int i=0;i<n;i++)
		{
			per[i].score=(300/max1)*per[i].round1*0.3+(300/max2)*per[i].round2*0.7;//算分 
		}
		sort(per,per+n,cmp);
		if(flagnv==0)//没女生,直接按排名输出 
		{
			printf("The member list of Shandong team is as follows:\n");
			for(int i=0;i<m;i++)
			{
				printf("%s\n",per[i].name);
			}
		}
		else
		{
			int flag;//标记排名中第一位女生排第几位 
			for(int i=0;i<n;i++)
			{
				if(per[i].sex==0)
				{
					flag=i;
					break;
				}
			}
			if(flag>m-1)//第一位女生不在选拔的队伍里,即选出的队伍里没有女生,那么让她替代队伍里的最后一名 
			{
				strcpy(per[m-1].name,per[flag].name);
				printf("The member list of Shandong team is as follows:\n");
				for(int i=0;i<m;i++)
				{
					printf("%s\n",per[i].name);
				}
				
			}
			else//选拔出来的队伍里有女生,那么直接按排名输出 
			{
				printf("The member list of Shandong team is as follows:\n");
				for(int i=0;i<m;i++)
				{
					printf("%s\n",per[i].name);
				}
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值