HDU:1789 Doing Homework again(经典贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11332    Accepted Submission(s): 6661


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1257  1978  1421  2159  1159 


题目大意:
给你n门课程,第一行为第i个课程的作业提交的期限,第二行为第i个课程作业如果未完成所扣的分数,求所扣最少分数为多少。

解题思路:
要求扣分最少,则将扣的分从大到小排序,先安排扣分最多的作业,如第i个课程,以该课程结束时间为初始点,向前扫描,看它能安排到第几天(每个课程尽量在接近截止日期完成,贪心。。)



#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int day,jianfen;
};
bool cmp(struct node a,struct node b)
{
	if(a.jianfen==b.jianfen)
	{
		return a.day<b.day;
	}
	else
	{
		return a.jianfen>b.jianfen;
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		struct node per[1010];
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&per[i].day);
		}
		for(int i=0;i<n;i++)
		{
			scanf("%d",&per[i].jianfen);
		}
		sort (per,per+n,cmp);
		int flag[1010];//标记第几天已经被安排 
		memset(flag,0,sizeof(flag));
		int sum=0;
		for(int i=0;i<n;i++)
		{
			int biao=0;//0表示当前的科目无法安排,1表示能安排 
			for(int j=per[i].day;j>=1;j--)
			{
				if(flag[j]==0)
				{
					flag[j]=1;
					biao=1;
					break;
				}
			}
			if(biao==0)
			{
				sum=sum+per[i].jianfen;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值