HDU:2199 Can you solve this equation?(二分)

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16582    Accepted Submission(s): 7365


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 

Author
Redow
 

Recommend

lcy


题目大意:给你一个y然后让你在[0,100]这个区间内找题中式子的可行解。

解题思路:将0和100分别带入上式,找出no solution的区域,如果输入不符合的话,就直接输出no solution。然后l=0,r=100这个区间内二分求解。

代码如下:

#include <cstdio>
#include <cmath>
double y;
bool judge(double x)
{
	if((8.0*pow(x,4.0)+7.0*pow(x,3.0)+2.0*pow(x,2.0)+3.0*x+6.0)>y)
	return true;
	else
	return false;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		if(y<6||y>(8.0*pow(100.0,4.0)+7.0*pow(100.0,3.0)+2.0*pow(100.0,2.0)+3.0*100+6.0))//找no solution的情况 
		{
			printf("No solution!\n");
		}
		else
		{
			double l=0,r=100;
			double mid;
			int size=100;
			while(size--)//100次肯定能搞到题目要求的精度 
			{
				mid=(l+r)/2.0;
				if(judge(mid))
				{
					r=mid;
				}
				else
				{
					l=mid;
				}
			}
			printf("%.4lf\n",mid);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值