HDU:1003 Max Sum(动态规划DP)

23 篇文章 0 订阅
2 篇文章 0 订阅

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 217253    Accepted Submission(s): 51248


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
题目大意:给你一个序列,让你输出这个序列最大子序列之和,再输出这个最大子序列的首尾元素的标号。
解题思路:与上一篇题目差不多一样,只不过细节不大一样,在代码里已经标注出来了,状态转移方程依然为dp[i]=max(a[i],dp[i-1]+a[i])。

代码如下:
#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
struct node
{
	int p;
	int i,j;
}dp[100010];
int a[100010];
bool cmp(struct node a,struct node b)
{
	if(a.p==b.p)
	{
		if(a.i==b.i)
		{
			return a.j<b.j;
		}
		else
		{
			return a.i<b.i;
		}
	}
	else
	{
		return a.p>b.p;
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	int hao=1;
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		dp[1].p=a[1];
		dp[1].i=1;
		dp[1].j=1;
		for(int i=2;i<=n;i++)
		{
			if(a[i]>dp[i-1].p+a[i])//7 0 6 -1 1 -6 7 -5,通过这个例子输出7 1 6可以看出 ,这里不加=号 
			{
				dp[i].p=a[i];
				dp[i].i=i;
				dp[i].j=i;
			}
			else
			{
				dp[i].p=dp[i-1].p+a[i];
				dp[i].i=dp[i-1].i;
				dp[i].j=i;
			}
		}
		sort(dp+1,dp+n+1,cmp);
		if(hao!=1)//题目中要求的格式,得有一个空行 
		{
			printf("\n");
		}
		printf("Case %d:\n",hao++);
		printf("%d %d %d\n",dp[1].p,dp[1].i,dp[1].j);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值