HDU:2602 Bone Collector(经典01背包)

23 篇文章 0 订阅
10 篇文章 0 订阅

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51939    Accepted Submission(s): 21876


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

Author
Teddy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1203  2159  2955  1171  2191 

题目大意:经典的背包问题,先给了你n个物品的价值,再给你n个物品的体积,还给了你背包的容积,问背包选择性的装物品后最大价值是多少?
解题思路:01背包的裸题。
代码如下:
二维实现:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[1010][1010];//dp[i][j]表示前i件物品装在容量为j的背包的总价值(前i件不一定全部装) 
int v[1010];//体积 
int val[1010];//价值 
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,V;
        scanf("%d%d",&n,&V);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=V;j++)
            {
                if(v[i]<=j)//表示第i件物品能装下
                {
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-v[i]]+val[i]);//装下的话,再判断装还是不装 
                }
                else
                {
                    dp[i][j]=dp[i-1][j];//装不下,那就不装 
                }
            }
        }
        printf("%d\n",dp[n][V]);
    }
    return 0;
}

滚动数组实现(因为这里只用到了前一种状态):
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[2][1010];//dp[i][j]表示前i件物品装在容量为j的背包的总价值(前i件不一定全部装) 
int v[1010];//体积 
int val[1010];//价值 
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,V;
        scanf("%d%d",&n,&V);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=V;j++)
            {
                if(v[i]<=j)//表示第i件物品能装下 
                {
                    dp[i%2][j]=max(dp[(i-1)%2][j],dp[(i-1)%2][j-v[i]]+val[i]);//装下的话,再判断装还是不装 
                }
                else//装不下,那就不装 
                {
                    dp[i%2][j]=dp[(i-1)%2][j];
                }
            }
        }
        printf("%d\n",dp[n%2][V]);
    }
    return 0;
}
一维实现:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[1010];
int v[1010];
int val[1010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,V;
		scanf("%d%d",&n,&V);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&val[i]);
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&v[i]);
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			for(int j=V;j>=v[i];j--)//倒着写,要不然会出现重复放置同一物品的情况 
			{
				dp[j]=max(dp[j],dp[j-v[i]]+val[i]);
			}
		}
		printf("%d\n",dp[V]);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值