HDU:1171 Big Event in HDU(经典01背包+转化)

23 篇文章 0 订阅
4 篇文章 0 订阅

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36183    Accepted Submission(s): 12561


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 

Author
lcy
 

Recommend
We have carefully selected several similar problems for you:   1203  2159  2955  2844  2191

题目大意:计算机学院要分成计算机学院和计算机软件学院两部分了,于是要分家,给了你一堆仪器的价值和数量,问如何才能做到均分,如果不能均分的话就让计算机学院稍多一点。
解题思路:比如一个仪器数量有n个,那么转化成n个价值一样的仪器,如此转化成01背包来做,由于计算机学院要多于等于软件学院的资源,那么先背包sum/2软件学院(sum是所有资源的总价值),然后剩余的就归计算机学院了。(先输出计算机学院获取的最终价值,再输出软件学院的)。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[501000];
int a[5010];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n<0)
		break;
		int sum=0;//机器总价值 
		int num=0;//机器总数 
		for(int i=0;i<n;i++)
		{
			int val,geshu;
			scanf("%d%d",&val,&geshu);
			sum=sum+geshu*val;
			while(geshu--)
			{
				a[num++]=val;
			}
		}
		memset(dp,0,sizeof(dp));
		for(int i=0;i<num;i++)
		{
			for(int j=sum/2;j>=a[i];j--)
			{
				dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
			}
		}
		printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值