Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 22081 Accepted Submission(s): 9443
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output
6 -1
Source
Recommend
题目大意:给你一个序列a,一个序列b,让你找到b十分存在于a中,存在的话输出b存在于a的起始地址(如果多个情况的话输出最小的),不存在的话输出-1.
解题思路:KMP模板题。
代码如下:
#include <cstdio>
#include <cstring>
int a[1000010];
int b[10010];
int next[10010];
int n,m,ans;
void makenext()
{
int k=0;
memset(next,0,sizeof(next));
for(int i=1;i<m;i++)
{
while(k>0&&b[k]!=b[i])
{
k=next[k-1];
}
if(b[k]==b[i])
{
k++;
}
next[i]=k;
}
}
void kmp()
{
int k=0;
for(int i=0;i<n;i++)
{
while(k>0&&b[k]!=a[i])
{
k=next[k-1];
}
if(b[k]==a[i])
{
k++;
}
if(k==m)//匹配完成
{
ans=i-m+2;//举个例子就知道了 1 2 1 2 3 1 2 3 1 3 2 1 2
// 1 2 3 1 3 9-5+2=6
return ;
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
for(int i=0;i<m;i++)
{
scanf("%d",&b[i]);
}
makenext();
ans=-1;//初始化ans
kmp();
printf("%d\n",ans);
}
return 0;
}