深搜2 poj 2448

poj  2448

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21891 Accepted: 7393

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
Accepted692K16MSG++1245B
输出一条遍历所有点的路径,要求每个点只能遍历一次,深搜找路径

按照字典序顺序输出遍历的路径,,dir为马走日的八个方向,按照字典序顺序遍历的八个方向为

int dx[8]={-2,-2,-1,-1,1,1,2,2},   //按字典序方向行走,用way记录走的路径,visit标记是否走过。。。
    dy[8]={-1,1,-2,2,-2,2,-1,1};

//rear是当前走的步数,下面是我徒手画的8个方向的排序


代码:

#include <cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define maxn 15
using namespace std;
int way[maxn*maxn][2],visit[maxn][maxn];
int dx[8]={-2,-2,-1,-1,1,1,2,2},   //按字典序方向行走
    dy[8]={-1,1,-2,2,-2,2,-1,1};
 int q,p;
bool dfs(int tot,int rear,int x,int y)
{
    int i,j,nx,ny;
    if(rear==tot)return 1; //搜索成功
    for(i=0;i<8;i++)
    {
      nx=x+dir[i][0];
      ny=y+dir[i][1];
      if(nx>=0&&nx<q&&ny>=0&&ny<p&&!visit[nx][ny])
      {
          visit[nx][ny]=1; //标记为经过
          if(dfs(tot,rear+1,nx,ny)) //搜索下一个
          {
              way[rear][0]=nx;
              way[rear][1]=ny;
              return 1;//搜索成功直接跳出,即为所走的路径
          }
          visit[nx][ny]=0; //搜索不成功,标记为未经过
      }
    }
    return 0;//搜索不成功
}
int main()
{
    int i,j,cas=1,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&p,&q);
        memset(visit,0,sizeof(visit));
        way[0][0]=0;way[0][1]=0;
        visit[0][0]=1; //标记A1已经经过
        printf("Scenario #%d:\n",cas++);
        if(dfs(p*q,1,0,0))
        {
            for(i=0;i<p*q;i++)
            printf("%c%d",way[i][0]+'A',way[i][1]+1);
        }
        else
        printf("impossible");
        printf("\n");
        if(t!=0)printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值