1325: 取球博弈
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 39 Solved: 23
[ Submit][ Status][ Web Board]
Description
今盒子里有n个小球,A、B两人轮流从盒中取球,每个人都可以看到另一个人取了多少个,也可以看到盒中还剩下多少个,并且两人都很聪明,不会做出错误的判断。
我们约定:
每个人从盒子中取出的球的数目必须是:1,3,7或者8个。
轮到某一方取球时不能弃权!
A先取球,然后双方交替取球,直到取完。
被迫拿到最后一个球的一方为负方(输方)
请编程确定出在双方都不判断失误的情况下,对于特定的初始球数,A是否能赢?
Input
标准输入获得数据,其格式如下:
先是一个整数n(n<100),表示接下来有n个整数。然后是n个整数,每个占一行(整数<10000),表示初始球数。
Output
程序输出n行,表示A的输赢情况(输为0,赢为1)。
Sample Input
4
1
2
10
18
Sample Output
0
1
1
0
import java.util.*;
/*
* 暴力破解
*/
public class 取球博弈 {
static int[] b={0,0,1,0,1,0,1,0,1,1,1,1,1,1,1,1};
public static void main(String[] args) {
Scanner in=new Scanner(System.in);
int n=in.nextInt();
int t=0;
int[] a=new int[100];
for(int i=0;i<n;i++)
a[i]=in.nextInt();
while(t<n) {
a[t]%=15;
if(a[t]==0)
a[t]=15;
System.out.println(b[a[t]]);
t++;
}
}
}