循环字符串的最小表示讲解 (POJ 1509 Glass Beads)

循环字符串的最小表示就是:

对于一个字符串S,求S的循环的同构字符串S’中字典序最小的一个。

用实际例子来解释:

设S=bcad,且S’是S的循环同构的串,则S’可以是bcad或者cadb,adbc,dbca。而且最小表示的S’是adbc。

两个字符串的大小比较,如果遇到字符字典序相同就比较下一个,即比较第一个不同的元素谁小。

对于字符串循环同构的最小表示,其问题实质是求S串的一个位置,从这个位置开始循环输出S,直到长度达到strlen(s)为止,得到的便是字典序最小的S’

方法:

int minString(char *s)//s的下标从0开始
{
	int len=strlen(s);
	int i=0,j=1,k=0;
	while(i<len&&j<len&&k<len) //两个出发位置从下标中选取 i,j<len  ,(最多有len位相同,如aaaa, len=4,以i=0,j=1开头的两个序列在k=4时循环结束) 
	{
		if(s[(i+k)%len]==s[(j+k)%len]) k++;
		else
		{
			if(s[(i+k)%len]>s[(j+k)%len]) 
			i=i+k+1;//从i为起点的序列和以j为起点的序列在经过k个元素的对应比较后,开始有不同的元素了,
			//并且这两个不同的元素相比,以j开头的那个要小于以i开头的那个,所以在长度相等的情况下以j开头的这一段要优于以i开头的那一段
			//所以就放弃以i开头,长度为k的序列,已经不是最优解了,就要把开头定在这个序列的后面,即新的i=i+k+1 
	        else j=j+k+1;//(即s[(i+k)%len]>s[(j+k)%len]时,以j开头的序列不是最优解) 
			if(i==j) j++;//保证两个序列的起点不一样
			k=0;//这里出现不同的元素后k就清0了,重新累加他们有多少个相同的元素,为了知道当出现不相等元素时不是最优解的序列应该把开头往后挪几位 		
		}
	}
	return min(i,j);//最优解是开头小的那个序列,因为不是最优解的已经加k往后试图寻找新的开头了,而当前最优解的开头还停留在原位,所以最优解永远是开头小的那个 
}
例题:
Glass Beads
Time Limit: 3000MS Memory Limit: 10000K
Total Submissions: 4817 Accepted: 2722

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace. 

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads. 

The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion. 

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

Output

For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

10
11
6
5

Source


AC代码:

//假设有两个下标i,j,表示如果从i和从j出发的字符串,有一个k表示字符串的长度,如果长度达到len,就表示找到最小的串
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int minString(char *s)
{
	int len=strlen(s);
	int i=0,j=1,k=0;
	while(i<len&&j<len&&k<len) //两个出发位置从下标中选取 i,j<len  ,(最多有len位相同,如aaaa, len=4,以i=0,j=1开头的两个序列在k=4时循环结束) 
	{
		if(s[(i+k)%len]==s[(j+k)%len]) k++;
		else
		{
			if(s[(i+k)%len]>s[(j+k)%len]) 
			i=i+k+1;//从i为起点的序列和以j为起点的序列在经过k个元素的对应比较后,开始有不同的元素了,
			//并且这两个不同的元素相比,以j开头的那个要小于以i开头的那个,所以在长度相等的情况下以j开头的这一段要优于以i开头的那一段
			//所以就放弃以i开头,长度为k的序列,已经不是最优解了,就要把开头定在这个序列的后面,即新的i=i+k+1 
	        else j=j+k+1;//(即s[(i+k)%len]>s[(j+k)%len]时,以j开头的序列不是最优解) 
			if(i==j) j++;//保证两个序列的起点不一样
			k=0;//这里出现不同的元素后k就清0了,重新累加他们有多少个相同的元素,为了知道当出现不相等元素时不是最优解的序列应该把开头往后挪几位 		
		}
	}
	return min(i,j);//最优解是开头小的那个序列,因为不是最优解的已经加k往后试图寻找新的开头了,而当前最优解的开头还停留在原位,所以最优解永远是开头小的那个 
}
int main()
{
	int t; 
	char s[100000];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",s);
		printf("%d\n",minString(s)+1);
	}
	return 0;
} 


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值