HDOJ 2122 Ice_cream’s world III(最小生成树prim算法)

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1223    Accepted Submission(s): 403


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
  
  
2 1 0 1 10 4 0
 

Sample Output
  
  
10 impossible
 
 
要考虑自环的情况,wa了两次。   最后一组数据也要输出空行,PE一次。
 
prim算法,代码如下:
 
<span style="font-size:12px;">#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
int n,map[1010][1010],sum;

void prim()
{
	sum=0;
	int i,j,next,min;
	int lowcost[1010],visit[1010];
	memset(visit,0,sizeof(visit));
	for(i=0;i<n;++i)
	   lowcost[i]=map[1][i];
	visit[1]=1;
	for(i=1;i<n;++i)
	{
		min=INF;
		for(j=0;j<n;++j)
		{
			if(!visit[j]&&min>lowcost[j])
			{
				min=lowcost[j];
				next=j;
			}
		}
		if(min==INF)
		{
			printf("impossible\n\n");
			return ;
		}
		sum+=min;
		visit[next]=1;
		for(j=0;j<n;++j)
		{
			if(!visit[j]&&lowcost[j]>map[next][j])
			    lowcost[j]=map[next][j];
		}   
	}
	printf("%d\n\n",sum);
}

int main()
{
	int m,i,j,x,y,c;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				if(i==j)
				   map[i][j]=0;//考虑自环的情况 
				else
				   map[i][j]=INF;
			}
		}
		while(m--)
		{
			scanf("%d%d%d",&x,&y,&c);
			if(map[x][y]>c)//自环的情况不计入 
			    map[x][y]=map[y][x]=c;
		}
		prim();	
	}
	return 0;
}
 </span>

 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值