hdoj 2122 Ice_cream’s world III 【最小生成树】

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1254    Accepted Submission(s): 414


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 


 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 


 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 


 

Sample Input
  
  
2 1 0 1 10 4 0
 


 

Sample Output
  
  
10 impossible

 

代码:

 

Kruskal算法:

 

#include<stdio.h>
#include<algorithm>
using namespace std;
struct record
{
	int s,e,w;
}num[10010];
bool cmp(record a,record b)
{
	return a.w<b.w;
}
int per[1010];
int m,n;
int init()
{
	for(int i=0;i<n;i++)
	{
		per[i]=i;
	}
}
int find(int x)
{
	int r;
	r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	per[x]=r;
	return r;
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fx]=fy;
		return true;
	}
	return false;
}
int main()
{
	int i,f,sum;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		f=1;
		sum=0;
		init();
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&num[i].s,&num[i].e,&num[i].w);
		}
		sort(num,num+m,cmp);
		for(i=0;i<m;i++)
		{
			if(join(num[i].s,num[i].e))
			{
				sum+=num[i].w;
				f++;
			}
		}
		if(f!=n)
		printf("impossible\n\n");
		else
		printf("%d\n\n",sum);
	}
	return 0;
}


Prim算法:

 

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f
int map[1010][1010],low[1010],vis[1010];
int n,m;
int init()
{
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			if(i==j)
			map[i][j]=map[j][i]=0;
			else
			map[i][j]=map[j][i]=INF;
		}
	}
}
void prim()
{
	int i,j,min,next,sum=0;
	for(i=0;i<n;i++)
	{
		vis[i]=0;
		low[i]=map[0][i];
	}
	vis[0]=1;
	for(i=1;i<n;i++)
	{
		min=INF;
		for(j=0;j<n;j++)
		{
			if(!vis[j]&&min>low[j])
			{
				min=low[j];
				next=j;
			}
		}
		if(min==INF)
		{
			printf("impossible\n\n");
			return ;
		}
		vis[next]=1;
		sum+=min;
		for(j=0;j<n;j++)
		{
			if(!vis[j]&&low[j]>map[next][j])
			{
				low[j]=map[next][j];
			}
		}
	}
	printf("%d\n\n",sum);
}
int main()
{
	int i,j,a,b,c;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
			map[a][b]=map[b][a]=c;
		}
		prim();
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值