POJ 3264 Balanced Lineup(线段树—求区间最大值与最小值差)

Balanced Lineup

Time Limit: 5000MS


Memory Limit: 65536K

Total Submissions: 41077


Accepted: 19305

Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.


Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.


Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.


Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2


Sample Output

6
3
0


题意:有一群排成一列的奶牛,让找出某个区间内奶牛们的最高身高与最低身高的差值。


题解:线段树问题,不能分别查找最大值,最小值,很耗时。与南阳上士兵杀敌(三)问题相同。


代码如下:


#include<cstdio>
#define INF 0x3f3f3f3f
int Max,Min;
struct node
{
	int left,right,max,min;
}num[200000];

int MAX(int a,int b)
{
	return a>b?a:b;
}

int MIN(int a,int b)
{
	return a<b?a:b;
}

void build(int left,int right,int cnt)
{
	int mid;
	num[cnt].left=left;
	num[cnt].right=right;
	if(left==right)
	{
		scanf("%d",&num[cnt].max);
		num[cnt].min=num[cnt].max;
		return ;
	}
	mid=(left+right)>>1;
	build(left,mid,cnt*2);
	build(mid+1,right,cnt*2+1);
	num[cnt].max=MAX(num[cnt*2].max,num[cnt*2+1].max);
	num[cnt].min=MIN(num[cnt*2].min,num[cnt*2+1].min);
}

void query(int left,int right,int cnt)
{
	int  mid;
	if(left==num[cnt].left&&right==num[cnt].right)
	{
		Max=MAX(Max,num[cnt].max);
		Min=MIN(Min,num[cnt].min);
		return ;
	}
	mid=(num[cnt].left+num[cnt].right)>>1;
	if(right<=mid)
		query(left,right,cnt*2);
	else if(left>mid)
		query(left,right,cnt*2+1);
	else
	{
		query(left,mid,cnt*2);
		query(mid+1,right,cnt*2+1);
	}	
}

int main()
{
	int N,Q,a,b;
	while(scanf("%d%d",&N,&Q)!=EOF)
	{
		build(1,N,1);
		while(Q--)
		{
			scanf("%d%d",&a,&b);
			Max=-1;
			Min=INF;
			query(a,b,1);
			printf("%d\n",Max-Min);
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值