Balanced Lineup(POJ 3264 线段树 )多次求任意区间最大值与最小值的差

Balanced Lineup(点击转到

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 64368 Accepted: 30003
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

1.题目含义:

    给定Q (1 ≤ Q ≤ 200,000)个数A1,A2 … AQ,,多次求任一区间Ai – Aj中最大数和最小数的差。

2.线段树:

   2.1线段树适用于和区间统计有关的问题,当题目中有 “区间”,‘’任意“,多次”等词汇的时候,便要考虑用线段树分区间进行求解。

   2.2线段树的过程就分为:建线段树——插入数据——查询更新的一个过程。

3.注意:

  用指针的形式还是用数组形式(下标从零开始)

  

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int nmax=-inf;
int nmin=inf;
struct node
{
	int l,r;
	int nmax;
	int nmin;
	int mid()
	{
		return  (l+r)/2;
	}
}tree[800010];
void buildTree(int root ,int l,int r)//root当前节点编号在数组中的下标(从0开始) 
{
	tree[root].l=l;
	tree[root].r=r;
	tree[root].nmax=-inf;
	tree[root].nmin=inf;
	int mid=(l+r)/2;
	if(l!=r)
	{
		buildTree(2*root+1,l,mid);
		buildTree(2*root+2,mid+1,r); 
	}
}
void insert(int root,int i,int v)//将第i个数,其值为v,插入到线段树编号为root的位置 
{
	if(tree[root].l==tree[root].r)
	{
		tree[root].nmax=tree[root].nmin=v;
		return ;
	}
	tree[root].nmax=max(tree[root].nmax,v);
	tree[root].nmin=min(tree[root].nmin,v);
	if(i<=tree[root].mid())
	{
		 insert(2*root+1,i,v);
	}
	else
	    insert(2*root+2,i,v);
}
void query(int root,int s,int e)
{
	if(tree[root].nmin>=nmin&&tree[root].nmax<=nmax)//最优性剪枝 
	    return ;
	if(tree[root].l==s&&tree[root].r==e)
	{
		nmin=min(tree[root].nmin,nmin);
	    nmax=max(tree[root].nmax,nmax);
	    return ;
	}
	if(e<=tree[root].mid())//在左边 
	{
		query(2*root+1,s,e);
	}
	else if(s>tree[root].mid())//在右边 
	{
		query(2*root+2,s,e);
	}
	else//在中间 
	{
		query(2*root+1,s,tree[root].mid());
	    query(2*root+2,tree[root].mid()+1,e);
	}

}                                                                                                                                                                                                                                                       
int main()
{
	int m,n;
	scanf("%d%d",&n,&m);
	buildTree(0,1,n);
	for(int i=1;i<=n;i++)
	{
		int num;
		scanf("%d",&num);
		insert(0,i,num);
	}
	for(int i=0;i<m;i++)
	{
		int s;
		int e;
		scanf("%d%d",&s,&e);
		nmin=inf;
		nmax=-inf;
		query(0,s,e);
		printf("%d\n",nmax-nmin);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值