POJ 3250 Bad Hair Day(单调栈stack)

Bad Hair Day

Time Limit: 2000MS


Memory Limit: 65536K

Total Submissions: 15958


Accepted: 5392

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5


题意:一群牛面朝右排列,个高的牛能看见前面个子低的牛的的头发,个子高的牛也能遮住后面个子低的牛的视线。给出这群牛从左到右的身高,求每头牛能看见的发型个数之和。


题解:比赛的时候根本没有想到用单调栈做,暴力果断超时了。这里把问题想成一只牛的发型能被其他几只牛看见?把每只牛压入栈,当下一只将要被压入栈的牛身高比栈顶牛高时,就代表栈顶牛的视线被遮住了,看不见接下来的牛了,则出栈。栈里剩下的牛的个数就是能看见将要入栈牛发型的个数。将每次求得的个数叠加就能得到结果。

代码如下:


#include<cstdio>
#include<stack>
using namespace std;
int main()
{
	int n,i;
	long long h,sum;//int会错,longlong过了 
	while(scanf("%d",&n)!=EOF)
	{
		stack<int>s;//注意更新 
		sum=0;
		scanf("%lld",&h);
		s.push(h);
		for(i=1;i<n;++i)
		{
			scanf("%lld",&h);
			while(!s.empty()&&h>=s.top())//相等也代表看不见前方牛了 
				s.pop();
			sum+=s.size();
			s.push(h);
		}
		printf("%lld\n",sum);
	}
	return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值