POJ 3273 Monthly Expense(二分搜索,最大化最小值)

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19454 Accepted: 7709

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:给出n天的花费,可以将它们分成m个月,只能相邻分在一个月,问单个月里的花费的最大值最小是多少。


题解:二分搜索,将单个月花费的最大值看做C,二分查找满足题意的C。 有很清晰的思路,写起来却漏洞百出。注意right的取值是每天的花费总和。


代码如下:


#include<cstdio>
#include<cstring>
int n,m;
int a[100010];

bool dix(int x)
{
	int next,cnt=0,i;
	for(i=0;i<m;++i)
	{
		int sum=a[cnt];
		while(sum<=x)
		{
			cnt++;
			sum+=a[cnt];		
			if(cnt==n)//天数使用完了,却没有到规定的月数,所以x的值取大了 
				return false;
		}
	}
	return true;
}

int main()
{
	int i,max;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		max=0;
		for(i=0;i<n;++i)
		{
			scanf("%d",&a[i]);
			max+=a[i];
		}
		int left=0,right=max+10,mid;
		while(left<right-1)
		{
			mid=(left+right)/2;
			if(dix(mid))
				left=mid;
			else
				right=mid;
		}
		printf("%d\n",right);
	}
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值