POJ 3187 Backward Digit Sums(next_permutation()暴力枚举)

Backward Digit Sums

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 5412


Accepted: 3123

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.


题意:有一个n,然后有从1~n这些数,按一定顺序排列,如上题中给出的相加方法,可以得到sum。现在给出n和sum,求最小的排列。

真是忠实函数狗,暴搜DFS从不练,一碰到这种题就直接next_permutation()函数了。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[15],b[15];
int main()
{
	int n,sum,i,k;
	while(scanf("%d%d",&n,&sum)!=EOF)
	{
		for(i=0;i<n;++i)
			a[i]=i+1;
		k=n-1;
		do
		{
			for(i=0;i<n;++i)
				b[i]=a[i];
			k=n;
			while(k--)
			{
				for(i=0;i<k;++i)
					b[i]+=b[i+1];
			}
			if(b[0]==sum)
				break;
		}while(next_permutation(a,a+n));
		for(i=0;i<n-1;++i)
			printf("%d ",a[i]);
		printf("%d\n",a[i]);
	}
	return 0;
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值