POJ 2229 Sumsets(递推)

Sumsets

Time Limit: 2000MS


Memory Limit: 200000K

Total Submissions: 14964


Accepted: 5978

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6


题意:给出一个数字n,问这个n有多少种由2的次幂之和组成的形式。


题解:可以直接列举递推:

n:                                                     ans:

    1                                                          1

    2                                                          2

    3                                                          2

    4                                                          4

    5                                                          4

    6                                                          6

    7                                                          6

    8                                                          10

    9                                                          10

    10                                                        14

    11                                                        14

    12                                                         20

     ......                                                        ......

if(n&1)                                                       a[n]=a[n-1]

if(n%2==0)                                                a[n]=(a[n-2]+a[n>>1])%1000000000


由上述递推过程很容易发现递推结果,不过可能会由于列举的数字不多,只列举了前7个,误认为递推关系是               if(n&1)  a[n]=a[n-1];    if(n%2==0)  a[n]=n    弱鸡的我就是这么想的(;′⌒`)。


还有一种利用二进制递推的方式,讨论区看来的啦:

可以将n用二进制表示.

n=1,只有1种表示方法。

n=2,10(2),二进制表示下,可以分拆成{1,1},{10}有两种表示方法

n=3, 11(2),可以分拆成{1,1,1},{10,1}.

n=4, 100(2),{1,1,1,1},{10,1,1},{10,10},{100}.

.........

总结:如果所求的n为奇数,那么所求的分解结果中必含有1,因此,直接将n-1的分拆结果中添加一个1即可 为s[n-1]
如果所求的n为偶数,那么n的分解结果分两种情况

1.含有1 这种情况可以直接在n-2的分解结果中添加两个1即可,这种情况有 s[n-1]

2.不含有1 那么,分解因子的都是偶数,将每个分解的因子都除以2,刚好是n/2的分解结果,并且可以与之一一对应,这种情况有 s[n/2]


Attention:just one test case,代码如下:


#include<cstdio>
#include<cstring>
int a[1000010];
int main()
{
	int n,i;
	a[1]=1; a[2]=2;
	for(i=3;i<1000001;++i)
	{
		if(i&1)
			a[i]=a[i-1];
		else
			a[i]=(a[i-2]+a[i>>1])%1000000000;
	}
	scanf("%d",&n);
	printf("%d\n",a[n]);
	return 0;
} 


                     

 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值