HDOJ 1060 Leftmost Digit(数学,求n^n的最高位)



Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15428    Accepted Submission(s): 5983


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
题意:求n^n的最高位的数字

题解:数学渣哭一会,推导能力太差啊

首先我们用科学计数法可以表示 num^num = a * 10^(n)  (a就是最高位数字)

等式两边同时用log10取对数得  num * lg(num) = n + lg(a)

设 x = n + lg(a) = num * lg(num)

因为a小于10,所以n为x的整数部分, lg(a)为x的小数部分;

又因为lg(a) = x-n, 所以lg(a) = x - (int)x  得到: a = pow( 10.0 , x-(int)x ) 。

又因为x = num * lg(num) ,所以就能得到 n^n的最高位的数字。

代码如下:

#include<cstdio>
#include<cmath>
#include<cstring>
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		__int64 n;
		scanf("%I64d",&n);
		double x=n*log10(n*1.0);
		x-=(__int64)x;
		int ans=pow(10.0,x);
		printf("%d\n",ans);
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值