POJ 2566 Bound Found Time(尺取法—前缀和排序处理)

Bound Found
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 2380 Accepted: 735 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

题意:数列中有n个数字,给出k个数,做k次查询,求在数列中存在的区间[ left,right ],使得区间中数的和的绝对值与t最接近。


题解:基本思路:统计出前缀和,然后找到两段前缀和差的绝对值最接近t。  我们用尺取法,需要先将前缀和从小到大排好序,这样才能用尺取法推进查找记录最小值。 在建立前缀和时,建立编号记录下标,通过编号还原位置。


代码如下:


#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
int a[100100],n,k;
struct node
{
	int sum,id;
}pre[100100];

int cmp(node a,node b)
{
	return a.sum<b.sum;
}

int main()
{
	int i,ans_left,ans_right,ans,sub,t;
	while(scanf("%d%d",&n,&k)&&n||k)
	{
		pre[0].sum=0;
		pre[0].id=0;
		for(i=1;i<=n;++i)
		{
			scanf("%d",&a[i]);
			pre[i].id=i;
			pre[i].sum=pre[i-1].sum+a[i];
		}
		sort(pre,pre+n+1,cmp);
		while(k--)
		{
			scanf("%d",&t);
			int left=0,right=1;
			int res=0x3f3f3f3f;
			while(right<=n)
			{
				sub=pre[right].sum-pre[left].sum;
				if(abs(sub-t)<res)
				{
					res=abs(sub-t);
					ans_left=min(pre[left].id,pre[right].id)+1;//注意前缀和大的可能对应下标在前面 
					ans_right=max(pre[left].id,pre[right].id);
					ans=sub;
				}
				if(sub<t)
					right++;
				else if(sub>t)
					left++;
				else//sub与t相等已是最佳区间,可以停止查找了 
					break;
				if(left==right)
					right++;
			}
			printf("%d %d %d\n",ans,ans_left,ans_right);
		}
	}
	return 0; 
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值