HDU 1130 How Many Trees?

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1130


How Many Trees?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3458    Accepted Submission(s): 1994


Problem Description

A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices).

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?
 

Input

The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 

Output

You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input

  
  
1 2 3
 

Sample Output

  
  
1 2 5
 

Source

 

Recommend

Eddy

思路:原生态的卡特兰数。因数据太大,用Java实现方便,所以用Java搞定。


直接附上AC代码:


import java.math.BigInteger;
import java.util.Scanner;

public class Main{
	final static int maxn = 105;
	BigInteger ans[] = new BigInteger[maxn];
	public static void main(String args[]){
		Main t = new Main();
		t.ans[0] = t.ans[1] = BigInteger.ONE;
		t.ans[2] = BigInteger.valueOf((long)2);
		for (int i=3; i<maxn; ++i){
			t.ans[i] = (t.ans[i-1]).multiply(BigInteger.valueOf(4*i-2)).divide(BigInteger.valueOf(i+1));
		}
		Scanner in = new Scanner(System.in);
		while (in.hasNext()){
			int n = in.nextInt();
			System.out.println(t.ans[n]);
		}
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值