贪心 1014

Before bridges were common, ferries were used to transport cars across rivers. River ferries, unlike their larger cousins, run on a guide line and are powered by the river's current. Cars drive onto the ferry from one end, the ferry crosses the river, and the cars exit from the other end of the ferry.
There is a ferry across the river that can take n cars across the river in t minutes and return in t minutes. m cars arrive at the ferry terminal by a given schedule. What is the earliest time that all the cars can be transported across the river? What is the minimum number of trips that the operator must make to deliver all cars by that time?
 

Input
The first line of input contains c, the number of test cases. Each test case begins with n, t, m. m lines follow, each giving the arrival time for a car (in minutes since the beginning of the day). The operator can run the ferry whenever he or she wishes, but can take only the cars that have arrived up to that time.
 

Output
For each test case, output a single line with two integers: the time, in minutes since the beginning of the day, when the last car is delivered to the other side of the river, and the minimum number of trips made by the ferry to carry the cars within that time. <br> <br>You may assume that 0 < n, t, m < 1440. The arrival times for each test case are in non-decreasing order.
 

Sample Input
  
  
2 2 10 10 0 10 20 30 40 50 60 70 80 90 2 10 3 10 30 40
 

Sample Output
  
  
100 5

50 2

上船过桥问题

一直wrong 一直wrong 一直wrong 一直wrong

忧郁

判断最小次数 就是船一次要装最大的车数

保证每次船装最大

还要保证 时间最短

时间最短很好求

这个题不能想太多

想到这个船一次装这么多再回来怎么办

说到底这个车都要运

等待这车来在运

总之是好的

include<iostream>
#include<cstring>
#include<stdio.h>
#include<string>
#include<stack>
#include<map>
#include<vector>
#include<cmath>
#include<set>
#include<cctype>
#include<queue>
using namespace std;
int n,t,m;
int time[10000];

void clear() {
    memset(time,0,sizeof(time));
}
int main() {
    int Case;
    scanf("%d",&Case);
    while(Case--) {
        scanf("%d %d %d",&n,&t,&m);
        clear();
        int r = m%n;
        int k = m/n;
        int ans1 = 0,ans2;
        if(r)
            ans2 = k + 1;
        else
            ans2 = k;
        for(int i=1;i<=m;i++)
            scanf("%d",&time[i]);
        if(r)
            ans1 = time[r] + t * 2;
        int j = 1;
        while(j <= k) {
            if(ans1 >= time[j * n + r]) {
                ans1 += t * 2;
                if(j == k)
                    ans1 -= t;
            }
            else {
                ans1 = time[j * n + r] + t * 2;
                if(j == k)
                    ans1 -= t;
            }
            j++;
        }
        printf("%d %d\n",ans1,ans2);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值