Sicily 1366. Ferry Loading IV

1366. Ferry Loading IV

Constraints

Time Limit: 3 secs, Memory Limit: 32 MB

Description

Before bridges were common, ferries were used to transport cars across rivers. River ferries, unlike their larger cousins, run on a guide line and are powered by the river's current. Cars drive onto the ferry from one end, the ferry crosses the river, and the cars exit from the other end of the ferry.

There is an l-meter-long ferry that crosses the river. A car may arrive at either river bank to be transported by the ferry to the opposite bank. The ferry travels continuously back and forth between the banks so long as it is carrying a car or there is at least one car waiting at either bank. Whenever the ferry arrives at one of the banks, it unloads its cargo and loads up cars that are waiting to cross as long as they fit on its deck. The cars are loaded in the order of their arrival; ferry's deck accommodates only one lane of cars. The ferry is initially on the left bank where it broke and it took quite some time to fix it. In the meantime, lines of cars formed on both banks that await to cross the river.

Input

The first line of input contains c, the number of test cases. Each test case begins with l, mm lines follow describing the cars that arrive in this order to be transported. Each line gives the length of a car (in centimeters), and the bank at which the car arrives ("left" or "right").

Output

For each test case, output one line giving the number of times the ferry has to cross the river in order to serve all waiting cars.

Sample Input

4
20 4
380 left
720 left
1340 right
1040 left
15 4 
380 left
720 left
1340 right
1040 left
15 4 
380 left
720 left
1340 left
1040 left
15 4 
380 right
720 right
1340 right
1040 right

Sample Output

3
3
5
6
// Problem#: 1366
// Submission#: 3305864
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
#include <vector>
#include <algorithm>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <string>
#include <queue>
using namespace std;

int main() {

    std::cout.sync_with_stdio(false);
    
    int caseNum;
    cin >> caseNum;

    while (caseNum--) {
        int l, m;
        cin >> l >> m;
        l *= 100;
        int car, allCar = 0;
        int ans = 0;
        bool atLeft = true;
        string pos;

        queue<int> ll, rr;

        while (m--) {
            cin >> car >> pos;
            if (pos == "left") ll.push(car);
            else rr.push(car);
        }

        while (1) {
            while (!ll.empty() && ll.front() + allCar <= l) {
                allCar += ll.front();
                ll.pop();
            }
            allCar = 0;
            ans++;
            if (ll.empty() && rr.empty()) break;
            while (!rr.empty() && rr.front() + allCar <= l) {
                allCar += rr.front();
                rr.pop();
            }
            allCar = 0;
            ans++;
            if (ll.empty() && rr.empty()) break;
        }

        cout << ans << endl;
    }

    return 0;
}                                 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值