问题 A: Fibonacci

题目描述
The Fibonacci Numbers{0,1,1,2,3,5,8,13,21,34,55…} are defined by the recurrence:
F0=0 F1=1 Fn=Fn-1+Fn-2,n>=2
Write a program to calculate the Fibonacci Numbers.

输入
Each case contains a number n and you are expected to calculate Fn.(0<=n<=30) 。

输出
For each case, print a number Fn on a separate line,which means the nth Fibonacci Number.

样例输入

1

样例输出

1

思路:递归。

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 31;
int dp[maxn];

int F(int n) {
    if (n == 0 || n == 1) return 1;
    if (dp[n] != -1) {
        return dp[n];
    } else {
        dp[n] = F(n - 1) + F(n - 2);
        return dp[n];
    }
}

int main() {
    int n;
    fill(dp, dp + maxn, -1);
    while (scanf("%d", &n) != EOF) {
        printf("%d\n", F(n - 1));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值