1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31783    Accepted Submission(s): 14053


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 
自己独立完成的第一道深搜题,而且一遍就AC 了,哈哈。。。

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[30];
int vis[30];
int n,num,k;
int is_prime(int x)
{
    for(int i=2;i<=x/2;i++)
        if(x%i==0)
        return 0;
    return 1;
}
void dfs(int x,int num)
{
    if(num==n&&is_prime(x+1))
    {
        printf("%d",a[0]);
        for(int i=1;i<n;i++) printf(" %d",a[i]);
        printf("\n");
    }
    for(int i=1;i<=n;i++)
        if(vis[i]==0&&is_prime(i+x))
        {
            a[k++]=i;
            vis[i]=1;
            dfs(i,num+1);
            vis[i]=0;
            k--;
        }
}
int main()
{
    int count=0;

    while(scanf("%d",&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        a[0]=1;
        vis[1]=1;
        k=num=1;
        printf("Case %d:\n",++count);
        dfs(1,1);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值