1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 166919    Accepted Submission(s): 38960

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
   
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
   
   
Case 1: 14 1 4 Case 2: 7 1 6
 


以前做过这题,曾经是暴力结果超时,今天用dp来解决,挺好用,最后卡在了那个起点怎么求上,最后搜了一下解题报告,说是找到最大值然后往后推到起点位置,这个方法还不错
 
#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=100000+5;
int a[maxn],d[maxn];
int main()
{
    int t,countn=0;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            d[i]=a[i];
        }
       // memset(d,0,sizeof(d));
        //d[1]=a[1];
        int l=a[1];
        int s1=1,d1=n;
      //  cout<<d[1]<<endl;
        for(int i=2;i<=n;i++)
        {
         //d[i]=max(d[i],d[i-1]+a[i]);
         if(d[i]<d[i-1]+a[i])
             d[i]=d[i-1]+a[i];
         if(l<d[i]) l=d[i];
        }

        int sum=0,k=1;

        for(int i=1;i<=n;i++)
        {
            if(d[i]==l&&d[i+1]!=l)
            {

                d1=i;
                break;
            }
        }



       //cout<<l<<endl;

        for(k=d1;k>0;k--)
        {
          sum=sum+a[k];
          if(sum==l&&((sum+a[k-1])!=sum))
           {
               s1=k;
               break;
           }
        }
       //  cout<<sum<<endl;
    //    for(int i=1;i<=n;i++)
     //      cout<<d[i]<<" ";
        if(countn) printf("\n");
        printf("Case %d:\n",++countn);
        printf("%d %d %d\n",l,s1,d1);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值